《双陈记》情侣博客

位置:主页 > 工作那些事 > ExtJS3 不兼容IE9的解决方法

ExtJS3 不兼容IE9的解决方法

公司项目在测试中,发现在IE9中,ExtJS里的tree控件不能点击了。Google了一下,发现ExtJS3.0不支持IE9的,现在升级ExtJS已经不可能了,只有想其他办法,第一想法就是让IE9默认采用IE8的兼容模式运行,好像以前好像在哪见过这个代码,然后就Google了一下,果然找到答案了。

在页面<head></head>里面插入以下代码:<meta http-equiv=”X-UA-Compatible” content=”IE=EmulateIE8″ />  必须在head里的第一行插入,才行的。这样IE9打开该页面就默认用IE8的兼容模式进行渲染,不兼容的问题就解决了。

 



无觅相关文章插件

已经有11位童鞋留言了,还不来盖楼!

  1. 表示不是很懂,技术型人才呀

  2. 支持下,呵呵。还有,鼠标滑动时图片大小变化的效果是怎么实现的呀,求指教, :grin:

  3. 博主的文章很好,谢谢分享了。

  4. Tim

    可是这样设了.字体就会变小了.

  5. 光指定一个meta貌似还不太好使的啊

love730.com
To:双陈记

 疑问 冷笑 悲伤 坏蛋 感叹 微笑 脸红 大笑 吃惊 惊讶 困惑 酷 大声笑 恼火 古怪

您还可以输入300个字插入图片